couchbase_lite 2.8.1
couchbase_lite: ^2.8.1 copied to clipboard

Flutter plugin for Couchbase Lite Community Edition, an embedded lightweight, noSQL database with live synchronization and offline support on Android and iOS.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add couchbase_lite

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  couchbase_lite: ^2.8.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:couchbase_lite/couchbase_lite.dart';
30
likes
75
pub points
77%
popularity

Flutter plugin for Couchbase Lite Community Edition, an embedded lightweight, noSQL database with live synchronization and offline support on Android and iOS.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

weltbr01@gmail.com

License

MIT (LICENSE)

Dependencies

built_collection, built_value, crypto, encrypt, flutter, hex, meta, password_hash, uuid

More

Packages that depend on couchbase_lite