cotter 0.1.3
cotter: ^0.1.3 copied to clipboard

Flutter SDK for Cotter's Passwordless Authentication Service.

7
likes
80/ 130
pub points
58%
popularity

We analyzed this package on Sep 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 203 API elements (12.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:cotter/cotter.dart that imports:
  • package:cotter/src/tokens/cotterIDToken.dart that imports:
  • package:cotter/src/tokens/cotterJwtToken.dart that imports:
  • package:cotter/src/helper/jwt.dart that imports:
  • package:cotter/src/cotter.dart that imports:
  • package:cotter/src/models/user.dart that imports:
  • package:cotter/src/helper/storage.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.4.22.8.22.8.2
crypto^2.1.52.1.53.0.1
cryptography^1.4.11.4.12.0.2
device_info^1.0.01.0.02.0.2
email_validator^1.0.61.0.62.0.1
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.53.3.54.2.1
flutter_web_auth^0.2.40.2.40.3.1
http^0.12.20.12.20.13.3
jose^0.1.2+10.1.2+10.3.2
meta^1.2.41.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto_keys-0.1.40.3.0
device_info_platform_interface-1.0.12.0.1
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.1
pointycastle-2.0.13.3.4
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^1.4.1` on cryptography does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cryptography to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

7
likes
80
pub points
58%
popularity

Flutter SDK for Cotter's Passwordless Authentication Service.

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

async, crypto, cryptography, device_info, email_validator, flutter, flutter_secure_storage, flutter_web_auth, http, jose, meta

More

Packages that depend on cotter