core_plugin_flutter 1.0.7+25

Flutter Android iOS

A flutter plugin for my project.

0
likes
70 / 110
pub points
57 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/phoenix91love/core-plugin-flutter was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 276 out of 952 API elements (29.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:core_plugin_flutter/AnimatedDialog/animated_dialog.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:core_plugin_flutter/AnimatedDialog/animated_dialog.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:core_plugin_flutter/AnimatedDialog/animated_dialog.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:core_plugin_flutter/AnimatedDialog/animated_dialog.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:core_plugin_flutter/CommonApi/CommonAppApi.dart that imports:
  • package:core_plugin_flutter/core-plugin.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:core_plugin_flutter/CommonApi/CommonAppApi.dart that imports:
  • package:core_plugin_flutter/core-plugin.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 43 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/Common/CommonProvider.dart:8:8

  ╷
8 │   void InitReponseState() {
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/Common/CommonProvider.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/Common/CommonProvider.dart:15:8

   ╷
15 │   void UpdateState(ResponseState response, {bool append = false}) {
   │        ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/Common/CommonProvider.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animated_text_kit^2.2.02.4.12.4.1
animator^2.0.12.0.12.0.1
cached_network_image^2.3.02.3.32.3.3
connectivity^0.4.9+20.4.9+50.4.9+5
cupertino_icons^1.0.01.0.01.0.0
dio^3.0.103.0.103.0.10
equatable^1.2.51.2.51.2.5
flare_flutter^2.0.32.0.62.0.6
flutterflutter0.0.00.0.0
flutter_bloc^6.0.56.0.66.0.6
flutter_easyloading^2.0.02.0.02.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_screenutil^2.3.12.3.13.1.1
flutter_slidable^0.5.70.5.70.5.7
hive^1.4.41.4.4+11.4.4+1
hive_flutter^0.3.10.3.10.3.1
intl^0.16.10.16.10.16.1
json_annotation^3.0.03.1.03.1.0
local_auth^0.6.2+30.6.3+30.6.3+3
path_provider^1.6.111.6.211.6.21
provider^4.3.24.3.2+24.3.2+2
pull_to_refresh^1.6.01.6.21.6.2
queries^0.1.140.1.140.1.14
rxdart^0.24.00.24.10.24.1
shared_preferences^0.5.70.5.12+20.5.12+2
simple_animations^2.2.12.2.32.2.3
vector_math^2.0.82.1.0-nullsafety.32.1.0-nullsafety.3
Transitive dependencies
PackageConstraintCompatibleLatest
bloc-6.1.06.1.0
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
clock-1.0.11.1.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
connectivity_for_web-0.3.1+20.3.1+2
connectivity_macos-0.1.0+50.1.0+5
connectivity_platform_interface-1.0.61.0.6
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
flare_dart-2.3.42.3.4
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.0.02.0.0
flutter_plugin_android_lifecycle-1.0.111.0.11
flutter_spinkit-4.1.2+14.1.2+1
flutter_web_plugins-0.0.00.0.0
function_types-0.0.20.0.2
http-0.12.20.12.2
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
nested-0.0.40.0.4
octo_image-0.3.00.3.0
path-1.8.0-nullsafety.11.8.0-nullsafety.1
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
sa_anicoto-1.0.31.0.3
sa_multi_tween-1.1.31.1.3
sa_stateless_animation-1.0.31.0.3
sa_v1_migration-1.1.21.1.2
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
sqflite-1.3.1+21.3.1+2
sqflite_common-1.0.2+11.0.2+1
states_rebuilder-2.3.13.1.0
string_scanner-1.0.51.1.0-nullsafety.1
supercharged-1.10.01.10.0
supercharged_dart-1.2.01.2.0
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
uuid-2.2.22.2.2
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.1` on flutter_screenutil does not support the latest published version `3.1.1`

pubspec.yaml:26:23

   ╷
26 │   flutter_screenutil: ^2.3.1
   │                       ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs