cool_linter 2.2.2
cool_linter: ^2.2.2 copied to clipboard

linter for analyzing dart code by RegExp pattern

9
likes
70/ 130
pub points
54%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:cool_linter/cool_linter.dart that imports:
  • package:cool_linter/src/plugin.dart that imports:
  • package:cool_linter/src/checker.dart that imports:
  • package:cool_linter/src/rules/stream_subscription_rule/stream_subscription_rule.dart that imports:
  • package:cool_linter/src/rules/stream_subscription_rule/stream_subscription_visitor.dart that imports:
  • package:cool_linter/src/rules/stream_subscription_rule/stream_subscription_result.dart that imports:
  • package:cool_linter/src/rules/ast_analyze_result.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast_factory.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/types_builder.dart that imports:
  • package:analyzer/src/dart/analysis/session.dart that imports:
  • package:analyzer/src/dart/element/inheritance_manager3.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

bin/cool_linter_cli.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/checker.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.7.01.7.22.3.0
analyzer_plugin^0.6.00.6.00.7.0
args^2.2.02.3.02.3.0
collection^1.15.01.15.01.15.0
file^6.1.06.1.26.1.2
freezed_annotation^0.14.20.14.30.14.3
glob^2.0.12.0.12.0.1
json_annotation^4.0.14.1.04.1.0
json_serializable^4.1.34.1.45.0.1
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
pub_semver^2.0.02.1.02.1.0
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.026.0.0
async-2.8.22.8.2
build_config-1.0.01.0.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.30.3.3
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.1.02.1.0
logging-1.0.21.0.2
package_config-2.0.22.0.2
pubspec_parse-1.1.01.1.0
source_gen-1.0.31.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.7.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.6.0` on analyzer_plugin does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions analyzer_plugin to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Dart 2.14.1.