connectanum 2.1.0 copy "connectanum: ^2.1.0" to clipboard
connectanum: ^2.1.0 copied to clipboard

This is a WAMP client (Web Application Messaging Protocol) implementation for the dart language and flutter projects.

9
likes
120/ 140
pub points
70%
popularity

We analyzed this package 11 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

168 out of 597 API elements (28.1 %) have documentation comments.

Some symbols that are missing documentation: authentication, authentication.AbstractAuthentication, authentication.AbstractAuthentication.AbstractAuthentication, authentication.CraAuthentication.defaultIterations, authentication.CraAuthentication.defaultKeyLength.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Unnecessary cast.

lib/src/authentication/cryptosign_authentication.dart:264:16

    ╷
264 │     mac.update(utf8.encode(macData.algorithm) as Uint8List, 0,
    │                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/authentication/cryptosign_authentication.dart

INFO: Unnecessary cast.

lib/src/authentication/cryptosign_authentication.dart:270:16

    ╷
270 │     mac.update(utf8.encode(macData.encryption) as Uint8List, 0,
    │                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/authentication/cryptosign_authentication.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cbor ^5.0.1 5.1.2 6.2.0
logging ^1.0.0 1.2.0 1.2.0
meta ^1.1.8 1.14.0 1.14.0
msgpack_dart ^1.0.0 1.0.1 1.0.1
pinenacl ^0.5.1 0.5.1 0.5.1
pointycastle ^3.3.5 3.9.0 3.9.0
saslprep ^1.0.1 1.0.2 1.0.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
hex - 0.2.0 0.2.0
ieee754 - 1.0.3 1.0.3
js - 0.7.1 0.7.1
pedantic - 1.11.1 1.11.1
typed_data - 1.3.2 1.3.2
unorm_dart - 0.2.0 0.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.1` on cbor does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions cbor to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

9
likes
120
pub points
70%
popularity

Publisher

verified publisherdart.konsultaner.de

This is a WAMP client (Web Application Messaging Protocol) implementation for the dart language and flutter projects.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cbor, logging, meta, msgpack_dart, pinenacl, pointycastle, saslprep

More

Packages that depend on connectanum