conduit_runtime 3.1.1 icon indicating copy to clipboard operation
conduit_runtime: ^3.1.1 copied to clipboard

SDKDart

Provides behaviors and base types for packages that can use mirrors and be AOT compiled.

1
likes
90/ 130
pub points
4%
popularity

We analyzed this package 16 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 109 API elements (29.4 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because conduit_runtime depends on fs_test_agent from path which doesn't exist (could not find package fs_test_agent at "../fs_test_agent"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Dart 2.17.0.

1
likes
90
pub points
4%
popularity

Publisher

verified publisher icontheconduit.dev

Provides behaviors and base types for packages that can use mirrors and be AOT compiled.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

analyzer, args, conduit_isolate_exec, path, pubspec, yaml

More

Packages that depend on conduit_runtime