conduit_config 3.1.1 icon indicating copy to clipboard operation
conduit_config: ^3.1.1 copied to clipboard

SDKDart

A safe and convenient way to read YAML configuration files.

2
likes
100/ 140
pub points
54%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 68 API elements (66.2 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:conduit_config/conduit_config.dart that imports:
  • package:conduit_config/src/default_configurations.dart that imports:
  • package:conduit_config/src/configuration.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
conduit_runtime^3.1.13.1.13.1.1
meta^1.3.01.8.01.8.0
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.049.0.0
analyzer-1.7.25.1.0
args-2.3.12.3.1
async-2.9.02.9.0
cli_util-0.3.50.3.5
collection-1.16.01.16.0
conduit_isolate_exec-3.1.13.1.1
convert-3.0.23.0.2
crypto-3.0.23.0.2
file-6.1.46.1.4
glob-2.1.02.1.0
matcher-0.12.120.12.12
package_config-2.1.02.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-2.1.12.1.1
pubspec-2.3.02.3.0
quiver-3.1.03.1.0
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-1.0.01.0.0
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Dart 2.18.2.

2
likes
100
pub points
54%
popularity

Publisher

verified publisher icontheconduit.dev

A safe and convenient way to read YAML configuration files.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

conduit_runtime, meta, yaml

More

Packages that depend on conduit_config