conduit 3.1.2 icon indicating copy to clipboard operation
conduit: ^3.1.2 copied to clipboard

SDKDart

A modern HTTP server application framework, ORM and OAuth2 provider with OpenAPI 3.0 integration. Foundation for REST, RPC or GraphQL services.

120
likes
100/ 140
pub points
89%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1018 out of 1342 API elements (75.9 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:conduit/conduit.dart that imports:
  • package:conduit/src/http/http.dart that imports:
  • package:conduit/src/http/serializable.dart that imports:
  • package:conduit_runtime/runtime.dart that imports:
  • package:conduit_runtime/src/mirror_coerce.dart that imports:
  • dart:mirrors
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Provide a deprecation message, via @Deprecated("message").

lib/src/auth/auth_code_controller.dart:13:1

   ╷
13 │ @deprecated
   │ ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/auth/auth_code_controller.dart

INFO: Provide a deprecation message, via @Deprecated("message").

lib/src/auth/auth_code_controller.dart:50:1

   ╷
50 │ @deprecated
   │ ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/auth/auth_code_controller.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.3.01.7.25.1.0
args^2.1.12.3.12.3.1
collection^1.15.01.16.01.16.0
conduit_common^3.1.13.1.13.1.1
conduit_config^3.1.13.1.13.1.1
conduit_isolate_exec^3.1.13.1.13.1.1
conduit_open_api^3.1.13.1.13.1.1
conduit_password_hash^3.1.13.1.13.1.1
conduit_runtime^3.1.13.1.13.1.1
crypto^3.0.03.0.23.0.2
logging^1.0.01.0.21.0.2
meta^1.1.51.8.01.8.0
path^1.6.11.8.21.8.2
postgres^2.3.12.5.22.5.2
pub_cache^0.3.00.3.10.3.1
pub_semver^2.0.02.1.12.1.1
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.049.0.0
async-2.9.02.9.0
buffer-1.1.11.1.1
cli_util-0.3.50.3.5
conduit_codable-3.1.13.1.1
convert-3.0.23.0.2
file-6.1.46.1.4
glob-2.1.02.1.0
matcher-0.12.120.12.12
package_config-2.1.02.1.0
pedantic-1.11.11.11.1
pubspec-2.3.02.3.0
quiver-3.1.03.1.0
sasl_scram-0.1.10.1.1
saslprep-1.0.21.0.2
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
unorm_dart-0.2.00.2.0
uri-1.0.01.0.0
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Dart 2.18.2.

120
likes
100
pub points
89%
popularity

Publisher

verified publisher icontheconduit.dev

A modern HTTP server application framework, ORM and OAuth2 provider with OpenAPI 3.0 integration. Foundation for REST, RPC or GraphQL services.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

analyzer, args, collection, conduit_common, conduit_config, conduit_isolate_exec, conduit_open_api, conduit_password_hash, conduit_runtime, crypto, logging, meta, path, postgres, pub_cache, pub_semver, yaml

More

Packages that depend on conduit