commons 0.7.8+3
commons: ^0.7.8+3 copied to clipboard

Commons Flutter package includes alert dialogs, extension functions and much more... Written by 'Ch Arbaz Mateen'

47
likes
60/ 130
pub points
88%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:632:9

    ╷
632 │ Author: <a href="http://arbazmateen.com/">Ch Arbaz Mateen</a></p>
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:34:61

   ╷
34 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 309 API elements (10.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:commons/commons.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/dialogs/alert_dialogs.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
data_connection_checker^0.3.40.3.40.3.4
date_format^1.0.81.0.92.0.4
device_info^0.4.2+40.4.2+102.0.3
flutterflutter0.0.00.0.0
get_version^0.2.0+10.2.20.2.2
http^0.12.10.12.20.13.4
intl^0.16.10.16.10.17.0
oktoast^2.3.02.3.23.1.5
package_info>=0.4.0+13 <2.0.00.4.3+42.0.2
progress_indicators^0.1.40.1.51.0.0
share^0.6.4+30.6.5+42.0.4
shared_preferences^0.5.70.5.12+42.0.9
time^1.2.01.4.12.0.1
url_launcher^5.4.15.7.106.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
device_info_platform_interface-1.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
mime-0.9.71.0.1
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.3
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 11 issues. Showing the first 2:

The constraint `^1.0.8` on date_format does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions date_format to update the constraint.

The constraint `^0.4.2+4` on device_info does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

47
likes
60
pub points
88%
popularity

Commons Flutter package includes alert dialogs, extension functions and much more... Written by 'Ch Arbaz Mateen'

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

data_connection_checker, date_format, device_info, flutter, get_version, http, intl, oktoast, package_info, progress_indicators, share, shared_preferences, time, url_launcher

More

Packages that depend on commons