common_bloc 4.2.0
common_bloc: ^4.2.0 copied to clipboard

A collection of common blocs and cubits that maybe will be used very often (powered by the bloc library).

8
likes
120/ 130
pub points
50%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 110 API elements (47.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^2.3.02.8.02.8.0
bloc^7.2.17.2.18.0.1
bloc_concurrency^0.1.00.1.00.2.0
dio^4.0.04.0.44.0.4
freezed_annotation^0.14.30.14.31.0.0
webfeed^0.7.00.7.00.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
glob-2.0.22.0.2
http_parser-4.0.04.0.0
intl-0.17.00.17.0
json_annotation-4.4.04.4.0
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
petitparser-4.4.04.4.0
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^7.2.1` on bloc does not support the stable version `8.0.0`, that was published 12 days ago.

When bloc is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^0.1.0` on bloc_concurrency does not support the stable version `0.2.0`, that was published 12 days ago.

When bloc_concurrency is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions bloc_concurrency to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

8
likes
120
pub points
50%
popularity

Publisher

pixela.tech

A collection of common blocs and cubits that maybe will be used very often (powered by the bloc library).

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, bloc, bloc_concurrency, dio, freezed_annotation, webfeed

More

Packages that depend on common_bloc