command_palette 0.7.4 copy "command_palette: ^0.7.4" to clipboard
command_palette: ^0.7.4 copied to clipboard

Flutter implementation of a Command Palette. Can be brought up via a keyboard shortcut.

17
likes
140/ 140
pub points
69%
popularity

We analyzed this package 27 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

67 out of 82 API elements (81.7 %) have documentation comments.

Some symbols that are missing documentation: command_palette, command_palette.CommandPalette.equals, command_palette.CommandPalette.focusNode, command_palette.CommandPalette.of, command_palette.CommandPaletteAction.CommandPaletteAction.input.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:command_palette/command_palette.dart that imports:
  • package:command_palette/src/command_palette.dart that imports:
  • package:command_palette/src/widgets/command_palette_modal.dart that imports:
  • package:command_palette/src/widgets/command_palette_text_field.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
substring_highlight ^1.0.33 1.0.33 1.0.33
woozy_search ^2.0.3 2.0.3 2.0.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

17
likes
140
pub points
69%
popularity

Publisher

verified publishertylernorbury.com

Flutter implementation of a Command Palette. Can be brought up via a keyboard shortcut.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, substring_highlight, woozy_search

More

Packages that depend on command_palette