code_preview 0.1.5 copy "code_preview: ^0.1.5" to clipboard
code_preview: ^0.1.5 copied to clipboard

flutter code preview

6
likes
130/ 160
pub points
67%
popularity

We analyzed this package 43 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 23 API elements (43.5 %) have documentation comments.

Some symbols that are missing documentation: code_preview, code_preview.CodeBuilder, code_preview.CodePreview, code_preview.CodePreview.CodePreview, code_preview.CodePreview.config.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/util/view_utils.dart:32:66

   ╷
32 │ OverlayState overlay(BuildContext context) => Overlay.of(context)!;
   │                                                                  ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/util/view_utils.dart

lib/src/code_preview/code_preview.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

6
likes
130
pub points
67%
popularity

Publisher

unverified uploader

flutter code preview

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on code_preview