code_editor 2.1.0 copy "code_editor: ^2.1.0" to clipboard
code_editor: ^2.1.0 copied to clipboard

A code editor (dart, js, html,...) for Flutter with syntax highlighting and custom theme.

97
likes
130/ 140
pub points
87%
popularity

We analyzed this package 43 hours ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/CodoPixel/code_editor was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

57 out of 82 API elements (69.5 %) have documentation comments.

Some symbols that are missing documentation: ToolButton, code_editor, code_editor.CodeEditor, code_editor.EditorModel.allFiles, code_editor.EditorModel.notify.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: The file name 'EditorModel.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/EditorModel.dart

INFO: The part-of directive uses a library name.

lib/EditorModel.dart:1:1

  ╷
1 │ part of code_editor;
  │ ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/EditorModel.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_highlight ^0.7.0 0.7.0 0.7.0
font_awesome_flutter ^10.1.0 10.7.0 10.7.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
highlight - 0.7.0 0.7.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

97
likes
130
pub points
87%
popularity

Publisher

verified publishersciencesky.fr

A code editor (dart, js, html,...) for Flutter with syntax highlighting and custom theme.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_highlight, font_awesome_flutter

More

Packages that depend on code_editor