cloud_functions_web 3.1.3
cloud_functions_web: ^3.1.3 copied to clipboard

Flutter web

The web implementation of cloud_functions

3
likes
60 / 110
pub points
97 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 70 API elements (27.1 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:cloud_functions_web/cloud_functions_web.dart that declares support for platforms: Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because no versions of firebase_core_web match >0.2.1+3 <0.2.2-nullsafety.0 and firebase_core_web >=0.2.2-nullsafety.0 depends on firebase_core_platform_interface ^3.0.2-nullsafety.0, firebase_core_web >0.2.1+3 requires firebase_core_platform_interface ^3.0.2-nullsafety.0.
And because firebase_core_web 0.2.1+3 depends on firebase_core_platform_interface ^3.0.1, firebase_core_web >=0.2.1+3 requires firebase_core_platform_interface ^3.0.1.
So, because cloud_functions_web depends on both firebase_core_web ^0.2.1+3 and firebase_core_platform_interface ^2.0.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs