large Flutter Favorite logosmall Flutter Favorite logo

cloud_functions 0.9.1-1.0.nullsafety.2 icon indicating copy to clipboard operation
cloud_functions: ^0.9.1-1.0.nullsafety.2 copied to clipboard

A Flutter plugin allowing you to use Firebase Cloud Functions.

257
likes
110/ 120
pub points
98%
popularity

We analyzed this package 12 days ago, and awarded it 110 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 10icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS, macOS, Web.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.15.1.

Because test <1.3.0 requires SDK version >=1.8.0 <2.0.0-∞ and test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0, test <1.3.0-∞ or >=1.16.0-nullsafety <1.16.0-n[...]
And because test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0 and test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nulls[...]
And because test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19 and test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0, test <1.12.0-∞ or >=1.16.0-nullsafety <1.16.6-∞ requires ty[...]
And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test <1.14.5-∞ or >=1.16.0-nullsafety <1.16.6-∞ requires typed_data >=1.3.0-null[...]
And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test <1.15.3-∞ or >=1.16.0-nullsafety <1.16.6-∞ requires typed_data >=1.3.0-null[...]
And because test >=1.15.3 <1.15.5 depends on test_api 0.2.18 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test <1.16.6 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_[...]
And because test >=1.16.0 <1.18.0 depends on pedantic ^1.10.0 and test >=1.18.0 <1.18.1 depends on test_api 0.4.4, test <1.18.1 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or[...]
And because test >=1.18.1 <1.19.0 depends on test_api 0.4.5 and test >=1.19.0 <1.19.3 depends on test_api 0.4.6, test <1.19.3 requires typed_data >=1.3.0-nullsafety <1.3.0 or test_api 0.2.14 or 0[...]
[5 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.