cloud_functions 0.9.0
cloud_functions: ^0.9.0 copied to clipboard

Flutter Android iOS web

A Flutter plugin allowing you to use Firebase Cloud Functions.

123
likes
110 / 110
pub points
97 %
popularity

We analyzed this package on Jan 20, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 12 API elements (83.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_functions_platform_interface^4.0.14.0.14.0.1
cloud_functions_web^3.1.33.1.33.1.3
firebase_core^0.7.00.7.00.7.0
firebase_core_platform_interface^3.0.13.0.13.0.1
meta^1.1.61.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
firebase_core_web-0.2.1+30.2.1+3
http_parser-3.1.43.1.4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
path-1.7.01.8.0-nullsafety.3
quiver-2.1.52.1.5
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs