large Flutter Favorite logosmall Flutter Favorite logo

cloud_functions 0.4.1+7 icon indicating copy to clipboard operation
cloud_functions: ^0.4.1+7 copied to clipboard

Flutter plugin for Cloud Functions.

257
likes
85/ 130
pub points
98%
popularity

We analyzed this package 11 days ago, and awarded it 85 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
5 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:8:15

  ╷
8 │ <li>Using the <a href="http://console.firebase.google.com/">Firebase Console</a>, add an Android app to your project:
  │               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 16 API elements (56.3 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:cloud_functions/cloud_functions.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_functions_platform_interface^1.0.01.1.05.0.20
firebase_core^0.4.00.4.51.11.0
flutterflutter0.0.00.0.0
meta^1.1.61.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
firebase-7.3.39.0.2
firebase_core_platform_interface-1.0.44.2.3
firebase_core_web-0.1.1+21.5.3
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
js-0.6.30.6.4
matcher-0.12.110.12.11
path-1.8.11.8.1
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.1.2
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on cloud_functions_platform_interface does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cloud_functions_platform_interface to update the constraint.

The constraint `^0.4.0` on firebase_core does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.28.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.