cloud_firestore_hooks 0.0.1+1
cloud_firestore_hooks: ^0.0.1+1 copied to clipboard

Provides common and reuseable hooks to be used in conjunction with cloud_firestore.

0
likes
120/ 130
pub points
0%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 5 API elements (20.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:cloud_firestore_hooks/cloud_firestore_hooks.dart that imports:
  • package:cloud_firestore_hooks/src/use_query.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^2.5.02.5.42.5.4
firebase_hooks_core^0.0.10.0.1+20.0.1+2
flutterflutter0.0.00.0.0
flutter_hooks^0.18.00.18.00.18.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
cloud_firestore_platform_interface-5.4.35.4.3
cloud_firestore_web-2.4.42.4.4
collection-1.15.01.15.0
firebase_core-1.8.01.8.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
120
pub points
0%
popularity

Provides common and reuseable hooks to be used in conjunction with cloud_firestore.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, firebase_hooks_core, flutter, flutter_hooks

More

Packages that depend on cloud_firestore_hooks