cloud_firestore 0.12.8
cloud_firestore: ^0.12.8 copied to clipboard

Flutter Android iOS

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

1127
likes
65 / 110
pub points
99 %
popularity

We analyzed this package on Feb 7, 2021, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/flutter/plugins/tree/master/packages/cloud_firestore was unreachable.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:9:15

  ╷
9 │ <li>Using the <a href="http://console.firebase.google.com/">Firebase Console</a>, add an Android app to your project:
  │               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 92 out of 130 API elements (70.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The value of the field '_firestore' isn't used.

lib/src/document_change.dart:40:19

   ╷
40 │   final Firestore _firestore;
   │                   ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/document_change.dart

INFO: The value of the field '_firestore' isn't used.

lib/src/query_snapshot.dart:37:19

   ╷
37 │   final Firestore _firestore;
   │                   ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/query_snapshot.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.31.15.0-nullsafety.51.15.0
firebase_core^0.4.00.4.50.7.0
meta^1.0.51.3.0-nullsafety.61.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0
charcode-1.2.01.2.0
firebase-7.3.38.0.0
firebase_core_platform_interface-1.0.43.0.1
firebase_core_web-0.1.1+20.2.1+3
http-0.12.20.13.0
http_parser-3.1.44.0.0
js-0.6.3-nullsafety.30.6.3
matcher-0.12.100.12.10
path-1.8.01.8.0
pedantic-1.10.01.10.0
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
source_span-1.7.01.8.1
stack_trace-1.10.01.10.0
string_scanner-1.0.51.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.0-nullsafety.51.3.0
vector_math-2.1.0-nullsafety.52.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on firebase_core does not support the latest published version `0.7.0`

pubspec.yaml:19:18

   ╷
19 │   firebase_core: "^0.4.0"
   │                  ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.25.0-8.3.pre, Dart 2.12.0 (build 2.12.0-133.7.beta).

1127
likes
65
pub points
99%
popularity

Publisher

firebase.google.com

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection, firebase_core, flutter, meta

More

Packages that depend on cloud_firestore