clearsale 1.0.0-dev.9
clearsale: ^1.0.0-dev.9

Dart native js
Flutter Android iOS web

Package para conectar uma aplicação Dart com a Clearsale

2
likes
80 / 110
pub points
12 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 395 out of 532 API elements (74.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Use `;` instead of `{}` for empty constructor bodies.

lib/src/infra/repositories/guarantee_repository_impl.dart:18:45

   ╷
18 │   GuaranteeRepositoryImpl(this._datasource) {}
   │                                             ^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/infra/repositories/guarantee_repository_impl.dart

lib/clearsale.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.131.14.131.14.13
dartz^0.9.10.9.20.9.2
http^0.12.20.12.20.12.2
meta^1.2.31.2.41.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
http_parser-3.1.43.1.4
path-1.7.01.7.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
80
pub points
12%
popularity

Package para conectar uma aplicação Dart com a Clearsale

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

davidsdearaujo@gmail.com

License

MIT (LICENSE)

Dependencies

collection, dartz, http, meta

More

Packages that depend on clearsale