clean_framework 1.3.1 icon indicating copy to clipboard operation
clean_framework: ^1.3.1 copied to clipboard

Clean Architecture components library, inspired on the guidelines created by Uncle Bob.

23
likes
100/ 130
pub points
78%
popularity

We analyzed this package 27 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 104 out of 643 API elements (16.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^3.1.143.1.183.1.18
either_dart^0.1.40.1.40.1.4
equatable^2.0.32.0.32.0.3
flutterflutter0.0.00.0.0
flutter_riverpod^1.0.41.0.41.0.4
flutter_testflutter0.0.00.0.0
go_router^3.1.03.1.14.1.0
gql^0.13.10.13.10.13.1
graphql^5.1.15.1.15.1.1
http^0.13.40.13.40.13.4
meta^1.7.01.7.01.8.0
riverpod^1.0.31.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.9.0
boolean_selector-2.1.02.1.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.01.1.1
cloud_firestore_platform_interface-5.5.85.5.8
cloud_firestore_web-2.6.172.6.17
collection-1.16.01.16.0
crypto-3.0.23.0.2
fake_async-1.3.01.3.1
firebase_core-1.18.01.18.0
firebase_core_platform_interface-4.4.14.4.1
firebase_core_web-1.6.51.6.5
flutter_web_plugins-0.0.00.0.0
gql_dedupe_link-2.0.22.0.2
gql_error_link-0.2.20.2.2
gql_exec-0.4.00.4.0
gql_http_link-0.4.20.4.2
gql_link-0.4.20.4.2
gql_transform_link-0.2.20.2.2
hive-2.2.22.2.2
http_parser-4.0.14.0.1
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.110.12.12
material_color_utilities-0.1.40.1.5
normalize-0.6.0+10.6.0+1
path-1.8.11.8.2
plugin_platform_interface-2.1.22.1.2
rxdart-0.27.40.27.4
sky_engine-0.0.990.0.99
source_span-1.8.21.9.0
stack_trace-1.10.01.10.0
state_notifier-0.7.2+10.7.2+1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.1
term_glyph-1.2.01.2.1
test_api-0.4.90.4.11
typed_data-1.3.11.3.1
uuid-3.0.63.0.6
vector_math-2.1.22.1.2
web_socket_channel-2.2.02.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.0` on go_router does not support the stable version `4.0.0`, that was published 9 days ago.

When go_router is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions go_router to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:clean_framework/clean_framework_defaults.dart that imports:
  • package:clean_framework/src/defaults/providers/graphql/src/graphql_service.dart that imports:
  • package:graphql/client.dart that imports:
  • package:graphql/src/graphql_client.dart that imports:
  • package:graphql/src/cache/cache.dart that imports:
  • package:graphql/src/cache/hive_store.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/box_collection/box_collection_indexed_db.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.