clean_dart_cli 1.1.1
clean_dart_cli: ^1.1.1 copied to clipboard

This project is one CLI for integrate Flutter and Dart with Clean Architecture

5
likes
100/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 193 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:clean_dart_cli/modules/app_module.dart that imports:
  • package:clean_dart_cli/modules/generate_layers/generate_module.dart that imports:
  • package:clean_dart_cli/modules/generate_layers/usecases/generate_usecases.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^2.0.12.0.12.0.1
args^2.1.02.3.02.3.0
cli_dialog^0.5.00.5.00.5.0
get_it^7.1.37.2.07.2.0
path^1.8.01.8.01.8.0
process_run^0.12.10.12.20.12.2
recase^4.0.04.0.04.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
dart_console-1.0.01.0.0
ffi-1.1.21.1.2
meta-1.7.01.7.0
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
win32-2.2.92.2.9
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.20.0, Dart 2.14.0.

5
likes
100
pub points
0%
popularity

This project is one CLI for integrate Flutter and Dart with Clean Architecture

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

ansicolor, args, cli_dialog, get_it, path, process_run, recase

More

Packages that depend on clean_dart_cli