chromeapi 0.0.8 copy "chromeapi: ^0.0.8" to clipboard
chromeapi: ^0.0.8 copied to clipboard

discontinuedreplaced by: chrome_extension
Platformweb

Chrome Extension API wrapper

4
likes
110/ 160
pub points
12%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

9 out of 171 API elements (5.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: tabs, tabs.ActiveInfo, tabs.ActiveInfo.ActiveInfo, tabs.ActiveInfo.tabId, tabs.ActiveInfo.windowId.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:chromeapi/tabs.dart that imports:
  • package:chromeapi/src/tabs/misc.dart that imports:
  • package:chromeapi/src/tabs/types.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:chromeapi/tabs.dart that imports:
  • package:chromeapi/src/tabs/misc.dart that imports:
  • package:chromeapi/src/tabs/types.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:chromeapi/tabs.dart that imports:
  • package:chromeapi/src/tabs/misc.dart that imports:
  • package:chromeapi/src/tabs/types.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:chromeapi/tabs.dart that imports:
  • package:chromeapi/src/tabs/misc.dart that imports:
  • package:chromeapi/src/tabs/types.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:chromeapi/tabs.dart that imports:
  • package:chromeapi/src/tabs/misc.dart that imports:
  • package:chromeapi/src/tabs/types.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The library 'package:chromeapi/src/tabs/main.dart' doesn't export a member with the hidden name 'chromeTabs'.

lib/tabs.dart:3:34

  ╷
3 │ export 'src/tabs/main.dart' hide chromeTabs;
  │                                  ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/tabs.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
js ^0.6.5 0.6.7 0.7.1
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.5` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

4
likes
110
pub points
12%
popularity

Publisher

unverified uploader

Chrome Extension API wrapper

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

js

More

Packages that depend on chromeapi