chgk_rating 1.0.2 copy "chgk_rating: ^1.0.2" to clipboard
chgk_rating: ^1.0.2 copied to clipboard

Dart wrapper client for the competitive What? Where? When? rating WebAPIRating https://api.rating.chgk.net/

1
likes
130/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/vmpay/chgk_rating_dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

34 out of 142 API elements (23.9 %) have documentation comments.

Some symbols that are missing documentation: chgk_rating.ChgkRating.ChgkRating.init, chgk_rating.Country.copyWith, chgk_rating.Country.Country.fromJson, chgk_rating.Country.Country.fromRawJson, chgk_rating.Country.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
dio ^4.0.0 4.0.6 5.4.3+1
meta ^1.3.0 1.14.0 1.14.0
mockito ^5.3.2 5.4.4 5.4.4
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
code_builder - 4.10.0 4.10.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

1
likes
130
pub points
0%
popularity

Publisher

verified publishervmpay.eu

Dart wrapper client for the competitive What? Where? When? rating WebAPIRating https://api.rating.chgk.net/

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

collection, dio, meta, mockito

More

Packages that depend on chgk_rating