chest_flutter 0.1.2
chest_flutter: ^0.1.2 copied to clipboard

Utilities for working with Chest and Flutter.

0
likes
90 / 130
pub points
24 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 12 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:chest_flutter/chest_flutter.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.4.22.6.12.6.1
chest^0.1.10.1.10.1.1
flutterflutter0.0.00.0.0
flutter_tapers^0.1.10.1.10.1.1
path_provider^2.0.02.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
clock-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.0.01.0.0
file-6.1.06.1.0
meta-1.3.01.3.0
more-3.0.13.0.1
path-1.8.01.8.0
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.