chat_gpt_api 2.0.0 copy "chat_gpt_api: ^2.0.0" to clipboard
chat_gpt_api: ^2.0.0 copied to clipboard

Chat GPT wrapper for flutter apps witten in dart language. Initial release supports Text Completion, Code Completion and Image Generation

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add chat_gpt_api

With Flutter:

 $ flutter pub add chat_gpt_api

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  chat_gpt_api: ^2.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:chat_gpt_api/app/api/api.dart';
import 'package:chat_gpt_api/app/chat_gpt.dart';
import 'package:chat_gpt_api/app/model/data_model/chat/chat_completion.dart';
import 'package:chat_gpt_api/app/model/data_model/chat/chat_request.dart';
import 'package:chat_gpt_api/app/model/data_model/completion/completion.dart';
import 'package:chat_gpt_api/app/model/data_model/completion/completion_request.dart';
import 'package:chat_gpt_api/app/model/data_model/image/image_request.dart';
import 'package:chat_gpt_api/app/model/data_model/image/images.dart';
import 'package:chat_gpt_api/app/model/models.dart';
import 'package:chat_gpt_api/chat_gpt.dart';
30
likes
110
pub points
76%
popularity

Publisher

verified publisherleyo.dev

Chat GPT wrapper for flutter apps witten in dart language. Initial release supports Text Completion, Code Completion and Image Generation

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dio

More

Packages that depend on chat_gpt_api