changelog 1.6.0
changelog: ^1.6.0 copied to clipboard

Helps to write your CHANGELOG.md

4
likes
50/ 130
pub points
16%
popularity

We analyzed this package 27 hours ago, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:113:45

    ╷
113 │ <p>If this tool is helpful for you - please <a href="http://gplus.mikemitterer.at/">(Circle)</a> me.</p>
    │                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 20 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-changelog/compare/v1.5...v1.6">v1.6</a> - 2018-08-14</h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 58 API elements (41.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:changelog/changelog.dart that imports:
  • package:git_version/git_version.dart that imports:
  • package:where/where.dart that imports:
  • package:where/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

bin/changelog.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/Application.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.01.6.02.3.0
console_log_handler^1.0.01.1.61.1.6
git_version^0.3.00.3.00.3.0
intl>=0.15.2 <1.0.00.17.00.17.0
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.32.62.8.0
ansicolor-1.1.12.0.1
async-2.8.22.8.2
build-0.12.82.1.1
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.17.10.17.1
file-5.2.16.1.2
front_end-0.1.4+20.1.29
glob-1.2.02.0.2
html-0.15.00.15.0
js-0.6.30.6.3
kernel-0.3.4+20.3.29
logging-0.11.41.0.2
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin-0.2.0+30.2.0+3
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
where-4.4.08.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.4.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.