celodart 0.0.1
celodart: ^0.0.1 copied to clipboard

A new package project to interact with the celo blockchain.

0
likes
75 / 130
pub points
3 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:67:1

   ╷
67 │ <a href="http://truffleframework.com/">truffle</a> and <a href="http://truffleframework.com/ganache/">ganache</a>. All these options will give you
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 280 out of 400 API elements (70.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/credentials/attestation.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.111.15.01.15.0
convert^2.1.12.1.13.0.1
flutterflutter0.0.00.0.0
http^0.12.00.12.20.13.3
isolate^2.0.02.1.12.1.1
json_rpc_2^2.1.02.2.23.0.1
meta^1.1.01.3.01.7.0
pointycastle^1.0.11.0.23.1.3
stream_channel^2.0.02.1.02.1.0
typed_data^1.1.61.3.01.3.0
uuid^2.0.02.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

0
likes
75
pub points
3%
popularity

A new package project to interact with the celo blockchain.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, convert, flutter, http, isolate, json_rpc_2, meta, pointycastle, stream_channel, typed_data, uuid

More

Packages that depend on celodart