cel 0.5.3 copy "cel: ^0.5.3" to clipboard
cel: ^0.5.3 copied to clipboard

This project parses and evaluates Common Expression Language (CEL) programs against some inputs.

3
likes
110/ 140
pub points
46%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 23 API elements (43.5 %) have documentation comments.

Some symbols that are missing documentation: cel.Ast, cel.Ast.Ast, cel.Ast.expression, cel.Environment, cel.Environment.adapter.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 104 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: RelativeAttribute.operand

lib/src/interpreter/attribute.dart:81:7

   ╷
81 │ class RelativeAttribute extends Attribute {
   │       ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/interpreter/attribute.dart

WARNING: The value of the local variable 'value' isn't used.

lib/src/interpreter/attribute.dart:89:11

   ╷
89 │     final value = operand.evaluate(activation);
   │           ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/interpreter/attribute.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
antlr4 ^4.11.1 4.13.1 4.13.1
collection ^1.16.0 1.18.0 1.18.0
equatable ^2.0.5 2.0.5 2.0.5
Transitive dependencies
Package Constraint Compatible Latest
logging - 1.2.0 1.2.0
meta - 1.14.0 1.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

3
likes
110
pub points
46%
popularity

Publisher

verified publisherwafrat.com

This project parses and evaluates Common Expression Language (CEL) programs against some inputs.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

antlr4, collection, equatable

More

Packages that depend on cel