carousel_nullsafety 0.1.1 copy "carousel_nullsafety: ^0.1.1" to clipboard
carousel_nullsafety: ^0.1.1 copied to clipboard

A Flutter Carousel pro widget.

5
likes
60/ 160
pub points
78%
popularity

We analyzed this package 15 hours ago, and awarded it 60 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/Alishawnee/carouselpro was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: carousel_nullsafety,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

7 out of 50 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: carousel_nullsafety, carousel_nullsafety.Carousel, carousel_nullsafety.Carousel.Carousel, carousel_nullsafety.Carousel.animationCurve, carousel_nullsafety.Carousel.animationDuration.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The argument type 'BorderRadius?' can't be assigned to the parameter type 'BorderRadiusGeometry'.

lib/carousel_nullsafety.dart:215:27

    ╷
215 │               borderRadius: widget.borderRadius!
    │ ┌───────────────────────────^
216 │ │                 ? BorderRadius.all(widget.radius!)
217 │ │                 : null,
    │ └──────────────────────^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/carousel_nullsafety.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/carousel_nullsafety.dart:23:9

   ╷
23 │   final defaultImage;
   │         ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/carousel_nullsafety.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • ARGUMENT_TYPE_NOT_ASSIGNABLE - lib/carousel_nullsafety.dart:215:27 - The argument type 'BorderRadius?' can't be assigned to the parameter type 'BorderRadiusGeometry'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

5
likes
60
pub points
78%
popularity

Publisher

unverified uploader

A Flutter Carousel pro widget.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on carousel_nullsafety