carousel_indicator 1.0.3
carousel_indicator: ^1.0.3 copied to clipboard

A Minimal and Simple carousel indicator library which take index as an argument and update indicator index. This library had pre-built slide animation.

8
likes
90 / 130
pub points
83 %
popularity

We analyzed this package on May 1, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 24 API elements (62.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/base_painter.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/carousel_indicator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carousel_slider^2.2.12.3.43.0.0
cupertino_icons^0.1.30.1.31.0.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.1` on carousel_slider does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions carousel_slider to update the constraint.

The constraint `^0.1.3` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

8
likes
90
pub points
83%
popularity

A Minimal and Simple carousel indicator library which take index as an argument and update indicator index. This library had pre-built slide animation.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

techskape@gmail.com

License

BSD (LICENSE)

Dependencies

carousel_slider, cupertino_icons, flutter

More

Packages that depend on carousel_indicator