camera_hooks 0.0.6
camera_hooks: ^0.0.6 copied to clipboard

Flutter hooks for Camera

1
likes
90/ 130
pub points
39%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:camera_hooks/camera_hooks.dart that imports:
  • package:camera_hooks/src/camera_controller_hook.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
camera^0.9.2+10.9.4+30.9.4+3
flutterflutter0.0.00.0.0
flutter_hooks^0.16.00.16.00.18.0
Transitive dependencies
PackageConstraintCompatibleLatest
camera_platform_interface-2.1.12.1.1
camera_web-0.2.1+10.2.1+1
characters-1.1.01.2.0
collection-1.15.01.15.0
cross_file-0.3.1+50.3.1+5
flutter_plugin_android_lifecycle-2.0.42.0.4
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-2.0.22.0.2
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.0` on flutter_hooks does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.