cafebazaar_auth 1.0.4 copy "cafebazaar_auth: ^1.0.4" to clipboard
cafebazaar_auth: ^1.0.4 copied to clipboard

PlatformAndroid

With this package you can use CafeBazaar auth and storage in flutter applications, This package only supports Android applications.

7
likes
130/ 140
pub points
30%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

13 out of 26 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: cafebazaar_auth, cafebazaar_auth.CafeBazaarAccount, cafebazaar_auth.CafeBazaarAccount.CafeBazaarAccount, cafebazaar_auth.CafeBazaarAccount.accountID, cafebazaar_auth.CafeBazaarAuth.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:cafebazaar_auth/cafebazaar_auth.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:cafebazaar_auth/cafebazaar_auth.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:cafebazaar_auth/cafebazaar_auth.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:cafebazaar_auth/cafebazaar_auth.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:cafebazaar_auth/cafebazaar_auth.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/cafebazaar_login_button.dart:18:14

   ╷
18 │     this.text: "ورود با بازار",
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cafebazaar_login_button.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/cafebazaar_login_button.dart:19:19

   ╷
19 │     this.textStyle: const TextStyle(
   │                   ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cafebazaar_login_button.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

7
likes
130
pub points
30%
popularity

Publisher

verified publisherarsam.me

With this package you can use CafeBazaar auth and storage in flutter applications, This package only supports Android applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on cafebazaar_auth