byteplot 0.1.3
byteplot: ^0.1.3 copied to clipboard

A Dart CLI tool for creating Flutter projects, applying templates, generating BLoC's and more!

5
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 27 API elements (51.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:byteplot/byteplot.dart that imports:
  • package:byteplot/src/commands/commands.dart that imports:
  • package:byteplot/src/commands/upgrade/upgrade_command.dart that imports:
  • package:byteplot/src/utilities/utilities.dart that imports:
  • package:byteplot/src/utilities/filesystem.dart that imports:
  • package:file/local.dart that imports:
  • package:file/src/backends/local.dart that imports:
  • package:file/src/backends/local/local_file_system.dart that imports:
  • package:file/src/backends/local/local_link.dart that imports:
  • package:file/src/backends/local/local_file_system_entity.dart that imports:
  • package:file/src/backends/local/local_file.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.12.0.1
args^1.5.21.6.02.0.0
file^5.1.05.2.16.1.0
http^0.12.0+20.12.20.13.1
mustache^1.1.11.1.11.1.1
mustache_recase^2.0.12.0.32.0.3
path^1.6.41.8.01.8.0
version^1.0.01.3.12.0.0
yaml^2.2.02.2.13.1.0
yamlicious^0.1.00.1.00.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
mustache_template-1.0.0+12.0.0
quiver-2.1.53.0.1
recase-3.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^1.0.2` on ansicolor does not support the stable version `2.0.1`, that was published 28 days ago.

When ansicolor is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

5
likes
90
pub points
0%
popularity

Publisher

baseflow.com

A Dart CLI tool for creating Flutter projects, applying templates, generating BLoC's and more!

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, file, http, mustache, mustache_recase, path, version, yaml, yamlicious

More

Packages that depend on byteplot