buy_me_a_coffee_widget 1.0.1 icon indicating copy to clipboard operation
buy_me_a_coffee_widget: ^1.0.1 copied to clipboard

Did you ever needed a widget for buy me a coffee, well here it is.

14
likes
110/ 140
pub points
46%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 59 out of 71 API elements (83.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:buy_me_a_coffee_widget/buy_me_a_coffee_widget.dart that imports:
  • package:buy_me_a_coffee_widget/src/buy_me_a_coffee_widget.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_svg^0.19.10.19.31.1.6
google_fonts^1.1.11.1.23.0.1
url_launcher^5.4.15.7.106.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.5
http_parser-3.1.44.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
path_drawing-0.4.1+11.0.1
path_parsing-0.1.41.0.1
path_provider-2.0.112.0.11
path_provider_android-2.0.92.0.22
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.32.0.6
path_provider_platform_interface-2.0.02.0.5
path_provider_windows-2.1.32.1.3
pedantic-1.11.11.11.1
petitparser-3.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher_linux-0.0.1+43.0.1
url_launcher_macos-0.0.1+93.0.1
url_launcher_platform_interface-1.0.92.1.1
url_launcher_web-0.1.5+32.0.13
url_launcher_windows-0.0.1+33.0.1
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2
xml-4.5.16.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint ^0.19.1 on flutter_svg does not support the stable version 0.21.0.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint ^1.1.1 on google_fonts does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions google_fonts to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.1.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

14
likes
110
pub points
46%
popularity

Publisher

verified publisher iconmyracledesign.de

Did you ever needed a widget for buy me a coffee, well here it is.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_svg, google_fonts, url_launcher

More

Packages that depend on buy_me_a_coffee_widget