built_tab_navigator 0.2.4
built_tab_navigator: ^0.2.4 copied to clipboard

Creates a Tab Style UI with Navigation capabilities.

4
likes
85 / 110
pub points
46 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be well formed Unable to parse 1 image link.

README.md:3:58

  ╷
3 │ <p>This Plugin is intended to be used in conjuntion with <a href="://pub.dev/packages/built_value">built_value</a> &amp; <a href="https://github.com/google/built_collection.dart">built_collection</a> since some of the API properties expect  <code>EnumClass</code> objects.</p>
  │                                                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 62 API elements (50.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Don't type annotate initializing formals.

lib/tab_navigator.dart:123:5

    ╷
123 │     T this.tab, {
    │     ^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/tab_navigator.dart

lib/tab_navigator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^5.0.05.0.05.0.0
built_value^8.0.08.0.58.0.5
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
fixnum-1.0.01.0.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

4
likes
85
pub points
46%
popularity

Creates a Tab Style UI with Navigation capabilities.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

victorevox@gmail.com

License

MIT (LICENSE)

Dependencies

built_collection, built_value, flutter

More

Packages that depend on built_tab_navigator