built_stream_generator 1.0.28 icon indicating copy to clipboard operation
built_stream_generator: ^1.0.28 copied to clipboard

Provide built stream for Dart This library is the dev dependency.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:built_stream_generator/built_stream_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform iOS

Because:

  • package:built_stream_generator/built_stream_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors

Package not compatible with platform Web

Because:

  • package:built_stream_generator/built_stream_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: 'displayName' is deprecated and shouldn't be used. Use getDisplayString instead.

lib/built_stream_generator.dart:23:26

   ╷
23 │             element.type.displayName == "SingleStream" ||
   │                          ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/built_stream_generator.dart

INFO: 'displayName' is deprecated and shouldn't be used. Use getDisplayString instead.

lib/built_stream_generator.dart:24:26

   ╷
24 │             element.type.displayName == "ComposedStreams");
   │                          ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/built_stream_generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.34.0 <=0.40.00.40.05.2.0
build^1.0.01.6.22.3.1
built_collection>=2.0.0 <5.0.04.3.25.1.1
built_stream^1.0.71.0.181.0.18
customized_streams^1.0.161.0.161.0.16
meta^1.1.81.8.01.8.0
source_gen^0.9.00.9.10+21.2.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-8.0.050.0.0
args-1.6.02.3.1
async-2.10.02.10.0
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.11.1.1
collection-1.17.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.16.20.17.2
dart_style-1.3.102.2.4
file-5.2.16.1.4
glob-1.2.12.1.1
html-0.14.0+40.15.1
intl-0.17.00.17.0
js-0.6.50.6.5
logging-1.1.01.1.0
matcher-0.12.130.12.13
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.3
quiver-2.1.53.1.0
rxdart-0.24.10.27.7
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint >=0.34.0 <=0.40.0 on analyzer does not support the stable version 0.40.1.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint ^1.0.0 on build does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.3.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
100
pub points
0%
popularity

Publisher

verified publisher iconvo9312.co

Provide built stream for Dart This library is the dev dependency.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, build, built_collection, built_stream, customized_streams, meta, source_gen

More

Packages that depend on built_stream_generator