built_bloc_generator 0.4.2
built_bloc_generator: ^0.4.2 copied to clipboard

Dart native

Generates the BLoC boilerplate.

4
likes
60 / 110
pub points
2 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 6 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:built_bloc_generator/built_bloc_generator.dart that imports:
  • package:built_bloc_generator/src/bloc_generator.dart that imports:
  • package:built_bloc_generator/src/generators/bloc.dart that imports:
  • package:built_bloc_generator/src/generators/bind.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

lib/src/bloc_generator.dart:16:47

   ╷
16 │       if (!element.allSupertypes.any((s) => s.name == "Bloc")) {
   │                                               ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc_generator.dart

INFO: Unused import: 'package:analyzer/dart/element/type.dart'.

lib/src/generators/bind.dart:2:8

  ╷
2 │ import 'package:analyzer/dart/element/type.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generators/bind.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.00.40.60.41.2
build^1.0.01.6.11.6.1
build_config>=0.3.1 <0.5.00.4.50.4.5
built_bloc^0.4.20.4.20.4.2
code_builder^3.5.03.6.03.6.0
dart_style^1.2.21.3.101.3.11
meta^1.1.81.2.41.2.4
path^1.7.01.7.01.7.0
source_gen^0.9.70.9.10+10.9.10+1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.014.0.0
args-1.6.01.6.0
async-2.4.22.4.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.41.0.4
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
matcher-0.12.90.12.9
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.70.1.7
quiver-2.1.52.1.5
rxdart-0.25.00.25.0
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.40.0` on analyzer does not support the latest published version `0.41.2`

pubspec.yaml:9:13

  ╷
9 │   analyzer: ^0.40.0
  │             ^^^^^^^
  ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs