build_vm_compilers 1.0.7 icon indicating copy to clipboard operation
build_vm_compilers: ^1.0.7 copied to clipboard

Builder implementations wrapping Dart VM compilers.

3
likes
50/ 130
pub points
38%
popularity

We analyzed this package 17 days ago, and awarded it 50 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...

stderr: FINE: Pub 2.15.1
SLVR: fact: build_vm_compilers is 1.0.7
SLVR: derived: build_vm_compilers
SLVR: fact: build_vm_compilers depends on analyzer ^1.0.0
SLVR: fact: build_vm_compilers depends on build ^1.0.0
SLVR: fact: build_vm_compilers depends on build_config >=0.3.0 <0.5.0
SLVR: fact: build_vm_compilers depends on build_modules ^2.0.0
SLVR: fact: build_vm_compilers depends on path ^1.6.0
SLVR: fact: build_vm_compilers depends on pool ^1.3.0
SLVR:   selecting build_vm_compilers
SLVR:   derived: pool ^1.3.0
SLVR:   derived: path ^1.6.0
SLVR:   derived: build_modules ^2.0.0
SLVR:   derived: build_config >=0.3.0 <0.5.0
SLVR:   derived: build ^1.0.0
SLVR:   derived: analyzer ^1.0.0
IO  : Get versions from https://pub.dartlang.org/api/packages/analyzer.
IO  : Get versions from https://pub.dartlang.org/api/packages/build.
IO  : Get versions from https://pub.dartlang.org/api/packages/build_config.
IO  : Get versions from https://pub.dartlang.org/api/packages/build_modules.
[...]
    | So, because build_vm_compilers depends on both analyzer ^1.0.0 and build_modules ^2.0.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 312:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 133:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 97:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 109:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 122:11                              captureErrors
    | package:pub/src/command.dart 180:13                            PubCommand.run
    | package:args/command_runner.dart 209:27                        CommandRunner.runCommand
    | package:dartdev/dartdev.dart 227:30                            DartdevRunner.runCommand
    | package:args/command_runner.dart 119:25                        CommandRunner.run.<fn>
    | dart:async                                                     new Future.sync
    | package:args/command_runner.dart 119:14                        CommandRunner.run
    | package:dartdev/dartdev.dart 66:29                             runDartdev
    | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----

icon indicating section status
Support multiple platforms
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because build_vm_compilers depends on _test_common from path which doesn't exist (could not find package _test_common at "../_test_common"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.4, Dart 2.15.1.