build_vm_compilers 1.0.13 copy "build_vm_compilers: ^1.0.13" to clipboard
build_vm_compilers: ^1.0.13 copied to clipboard

Builder implementations wrapping Dart VM compilers for modules and programs.

3
likes
130/ 160
pub points
8%
popularity

We analyzed this package 27 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/dart-lang/build/tree/master/build_vm_compilers was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: build_vm_compilers,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: build_vm_compilers.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 13 API elements (23.1 %) have documentation comments.

Some symbols that are missing documentation: build_vm_compilers, build_vm_compilers.vmPlatform, builders, builders.metaModuleBuilder, builders.metaModuleCleanBuilder.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:build_vm_compilers/build_vm_compilers.dart that imports:
  • package:build_vm_compilers/src/vm_entrypoint_builder.dart that imports:
  • package:build_vm_compilers/src/platform.dart that imports:
  • package:build_modules/build_modules.dart that imports:
  • package:build_modules/src/workers.dart that imports:
  • package:build_modules/src/scratch_space.dart that imports:
  • package:scratch_space/scratch_space.dart that imports:
  • package:scratch_space/src/scratch_space.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.1.0 <6.0.0 5.13.0 6.7.0
build ^2.0.0 2.4.1 2.4.1
build_config ^1.0.0 1.1.1 1.1.1
build_modules ^4.0.0 4.0.7 5.0.8
path ^1.8.0 1.9.0 1.9.0
pool ^1.5.0 1.5.1 1.5.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 72.0.0
async - 2.11.0 2.11.0
bazel_worker - 1.1.1 1.1.1
checked_yaml - 2.0.3 2.0.3
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
protobuf - 3.1.0 3.1.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
scratch_space - 1.0.2 1.0.2
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=5.1.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^4.0.0` on build_modules does not support the stable version `5.0.6`.

Try running dart pub upgrade --major-versions build_modules to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

3
likes
130
pub points
8%
popularity

Publisher

verified publishertools.dart.dev

Builder implementations wrapping Dart VM compilers for modules and programs.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, build_config, build_modules, path, pool

More

Packages that depend on build_vm_compilers