build_vm_compilers 1.0.6 icon indicating copy to clipboard operation
build_vm_compilers: ^1.0.6 copied to clipboard

Builder implementations wrapping Dart VM compilers.

3
likes
70/ 130
pub points
38%
popularity

We analyzed this package 16 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 14 API elements (21.4 %) have documentation comments.
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_vm_compilers/build_vm_compilers.dart that imports:
  • package:build_vm_compilers/src/vm_entrypoint_builder.dart that imports:
  • package:build_vm_compilers/src/platform.dart that imports:
  • package:build_modules/build_modules.dart that imports:
  • package:build_modules/src/workers.dart that imports:
  • package:build_modules/src/scratch_space.dart that imports:
  • package:scratch_space/scratch_space.dart that imports:
  • package:scratch_space/src/scratch_space.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because build_vm_compilers depends on _test_common from path which doesn't exist (could not find package _test_common at "../_test_common"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.