build_version 2.0.1

Dart native
Flutter Android iOS

A builder for extracting a package version into code.

6
likes
80 / 110
pub points
54 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_version/builder.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build>=0.12.1 <2.0.01.4.01.4.0
build_config>=0.3.0 <0.5.00.4.20.4.2
pubspec_parse^0.1.2+20.1.50.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.09.0.0
analyzer-0.39.170.40.2
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
json_annotation-3.0.13.0.1
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
80
pub points
54%
popularity

Publisher

j832.com

A builder for extracting a package version into code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

build, build_config, pubspec_parse

More

Packages that depend on build_version