build_shell 1.0.0
build_shell: ^1.0.0 copied to clipboard

Builds shell scripts that execute Dart snapshots (from build_vm_compilers).

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/thosakwe/build_shell was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/build_shell_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 6 API elements (66.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_shell/build_shell.dart that imports:
  • package:scratch_space/scratch_space.dart that imports:
  • package:scratch_space/src/scratch_space.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build^1.0.01.1.02.1.1
build_config^0.3.00.3.21.0.0
build_vm_compilers^0.1.10.1.21.0.9
path^1.0.01.8.01.8.0
scratch_space^0.0.30.0.4+31.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.33.3+22.8.0
args-1.6.02.3.0
async-2.8.22.8.2
bazel_worker-0.1.251.0.1
build_modules-1.0.114.0.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.17.10.17.1
file-5.2.16.1.2
fixnum-0.10.111.0.0
front_end-0.1.6+50.1.29
glob-1.2.02.0.2
graphs-0.2.02.1.0
html-0.15.00.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-2.4.04.4.0
kernel-0.3.6+50.3.29
logging-0.11.41.0.2
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
plugin-0.2.0+30.2.0+3
pool-1.5.01.5.0
protobuf-1.1.42.0.0
pub_semver-2.1.02.1.0
pubspec_parse-0.1.81.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint `^0.3.0` on build_config does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions build_config to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
80
pub points
0%
popularity

Builds shell scripts that execute Dart snapshots (from build_vm_compilers).

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build, build_config, build_vm_compilers, path, scratch_space

More

Packages that depend on build_shell