build_shell 1.0.0

build_shell #


Builds shell scripts that execute Dart snapshots (from build_vm_compilers).

Rationale #

This package alleviates an inconvenience - at this point in time, even though you can build .dill files via package:build_vm_compilers, those files are placed in the cache, rather than in your actual project. So, actually running them becomes a little more complex.

This tool just creates shell scripts to let you run them. This way, your script only has to be compiled once, leading to faster startup times.

Installation #

In your pubspec.yaml:

  build_shell: ^1.0.0
  build_runner: ^1.0.0

Usage #

Simply run:

pub run build_runner build.

You'll then see a .sh and .bat file generated for every Dart script with a main method.

1.0.0 #

  • Initial version, created by Stagehand


/// Empty file for the sake of Pub score...
void main() {

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  build_shell: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:build_shell/build_shell.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/build_shell.dart. (-0.50 points)

Analysis of lib/build_shell.dart reported 1 hint:

line 52 col 9: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (build_config, build_vm_compilers).

Package is getting outdated. (-4.93 points)

The package was last published 54 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
build ^1.0.0 1.2.2
build_config ^0.3.0 0.3.2 0.4.2
build_vm_compilers ^0.1.1 0.1.2 1.0.4
path ^1.0.0 1.6.4
scratch_space ^0.0.3 0.0.4+2
Transitive dependencies
analyzer 0.35.4 0.39.4
args 1.5.2
async 2.4.0
bazel_worker 0.1.23+1
build_modules 1.0.11 2.8.0
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
fixnum 0.10.11
front_end 0.1.14 0.1.29
glob 1.2.0
graphs 0.2.0
js 0.6.1+1
json_annotation 2.4.0 3.0.1
kernel 0.3.14 0.3.29
logging 0.11.4
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0 2.0.0
pedantic 1.9.0
pool 1.4.0
protobuf 1.0.1
pub_semver 1.4.3
pubspec_parse 0.1.5
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner ^1.0.0