build_pubspec 0.2.0+1 icon indicating copy to clipboard operation
build_pubspec: ^0.2.0+1 copied to clipboard

SDKDart

Extract pubspec details (such as package version, author and description) into Dart code.

5
likes
80/ 130
pub points
31%
popularity

We analyzed this package 3 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 3 API elements (33.3 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:build_pubspec/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build>=0.12.1 <2.0.01.6.32.3.0
build_config>=0.3.0 <0.5.00.4.71.0.0
meta^1.0.01.8.01.8.0
pubspec_parse^0.1.2+20.1.81.2.0
source_gen^0.9.40.9.10+31.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.040.0.0
analyzer-1.7.24.1.0
args-2.3.12.3.1
async-2.9.02.9.0
cli_util-0.3.50.3.5
collection-1.16.01.16.0
convert-3.0.13.0.1
crypto-3.0.23.0.2
dart_style-1.3.142.2.3
file-6.1.26.1.2
glob-2.0.22.0.2
json_annotation-4.5.04.5.0
logging-1.0.21.0.2
package_config-2.0.22.0.2
path-1.8.21.8.2
pub_semver-2.1.12.1.1
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
watcher-1.0.11.0.1
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=0.12.1 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

The constraint `>=0.3.0 <0.5.0` on build_config does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions build_config to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.0.

5
likes
80
pub points
31%
popularity

Publisher

verified publisher icondartside.dev

Extract pubspec details (such as package version, author and description) into Dart code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

build, build_config, meta, pubspec_parse, source_gen

More

Packages that depend on build_pubspec