build 1.6.2
build: ^1.6.2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

A build system for Dart.

18
likes
80 / 110
pub points
99 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 89 out of 149 API elements (59.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.35.0 <0.42.00.41.21.1.0
async>=1.13.3 <3.0.02.4.22.5.0
convert>=2.0.0 <4.0.02.1.13.0.0
crypto>=0.9.2 <4.0.02.1.53.0.0
glob>=1.1.0 <3.0.01.2.02.0.0
logging>=0.11.2 <2.0.00.11.41.0.0
meta^1.1.01.2.41.3.0
path^1.1.01.7.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
args-1.6.02.0.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
file-5.2.16.1.0
intl-0.16.10.17.0
js-0.6.20.6.3
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pub_semver-1.4.42.0.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.35.0 <0.42.0` on analyzer does not support the stable version `1.0.0`, that was published 15 days ago.

When analyzer is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.