boolean_lints 2.0.0 copy "boolean_lints: ^2.0.0" to clipboard
boolean_lints: ^2.0.0 copied to clipboard

discontinuedreplaced by: solid_lints

boolean_lints is a developer tool, designed to help stop common issue and simplify repetetive tasks. It adds various warnings with quick fixes and refactoring options.

2
likes
110/ 140
pub points
0%
popularity

We analyzed this package 18 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 2 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:boolean_lints/boolean_lints.dart that imports:
  • package:custom_lint_builder/custom_lint_builder.dart that imports:
  • package:custom_lint_core/custom_lint_core.dart that imports:
  • package:custom_lint_core/src/type_checker.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/error/error_code_values.g.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/fasta/doc_comment_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/resolver.dart that imports:
  • package:analyzer/src/generated/static_type_analyzer.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inference_helper.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inferrer.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/resolver/flow_analysis_visitor.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/types_builder.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/util/uri.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/pub.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/blaze.dart that imports:
  • package:analyzer/src/workspace/blaze_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'isValueEqual' is deprecated and shouldn't be used. Upgrade to dart_mappable_builder >= 4.2.2.

lib/src/lints/avoid_hardcoded_strings/models/avoid_hardcoded_strings_options.mapper.dart:99:18

   ╷
99 │                 .isValueEqual(this as AvoidHardcodedStringsOptions, other));
   │                  ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/lints/avoid_hardcoded_strings/models/avoid_hardcoded_strings_options.mapper.dart

INFO: 'isValueEqual' is deprecated and shouldn't be used. Upgrade to dart_mappable_builder >= 4.2.2.

lib/src/lints/banned_external_code/models/banned_code_options.mapper.dart:94:18

   ╷
94 │                 .isValueEqual(this as BannedCodeOptions, other));
   │                  ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/lints/banned_external_code/models/banned_code_options.mapper.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.12.0 <7.0.0 6.4.1 6.4.1
analyzer_plugin ^0.11.2 0.11.3 0.11.3
collection ^1.16.0 1.18.0 1.18.0
custom_lint_builder >=0.4.0 <0.6.0 0.5.14 0.6.4
dart_mappable >=3.0.1 <5.0.0 4.2.2 4.2.2
glob ^2.1.2 2.1.2 2.1.2
meta ^1.7.0 1.14.0 1.14.0
path ^1.8.1 1.9.0 1.9.0
pub_semver ^2.1.4 2.1.4 2.1.4
source_span ^1.8.0 1.10.0 1.10.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
checked_yaml - 2.0.3 2.0.3
ci - 0.1.0 0.1.0
cli_util - 0.4.1 0.4.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
custom_lint - 0.5.11 0.6.4
custom_lint_core - 0.5.14 0.6.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
freezed_annotation - 2.4.1 2.4.1
hotreloader - 4.2.0 4.2.0
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
package_config - 2.1.0 2.1.0
pubspec_parse - 1.2.3 1.2.3
rxdart - 0.27.7 0.27.7
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
type_plus - 2.1.1 2.1.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vm_service - 14.2.1 14.2.1
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.4.0 <0.6.0` on custom_lint_builder does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions custom_lint_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

2
likes
110
pub points
0%
popularity

Publisher

verified publishergetboolean.dev

boolean_lints is a developer tool, designed to help stop common issue and simplify repetetive tasks. It adds various warnings with quick fixes and refactoring options.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, analyzer_plugin, collection, custom_lint_builder, dart_mappable, glob, meta, path, pub_semver, source_span, yaml

More

Packages that depend on boolean_lints