blocify 0.1.0

Dart native js
Flutter Android iOS web

A library that makes using the BLoC (Business Logic Component) design pattern easier.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Aug 14, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 35 API elements (31.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/blocify.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/single_async_op_bloc.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^4.0.04.0.06.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
meta-1.2.21.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on bloc does not support the latest published version `6.0.1`

pubspec.yaml:12:9

   ╷
12 │   bloc: ^4.0.0
   │         ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

A library that makes using the BLoC (Business Logic Component) design pattern easier.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

sansmithdev@gmail.com

License

MIT (LICENSE)

Dependencies

bloc

More

Packages that depend on blocify