bloc_riverpod 0.0.2 copy "bloc_riverpod: ^0.0.2" to clipboard
bloc_riverpod: ^0.0.2 copied to clipboard

discontinuedreplaced by: riverbloc

BlocProvider implementation with riverpod as alternative to provider.

3
likes
130/ 140
pub points
0%
popularity

We analyzed this package 43 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

94 out of 100 API elements (94.0 %) have documentation comments.

Some symbols that are missing documentation: bloc_riverpod, bloc_riverpod.AutoDisposeBlocProvider.create, bloc_riverpod.AutoDisposeBlocProvider.family, bloc_riverpod.BlocProvider.autoDispose, bloc_riverpod.BlocProvider.create.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^7.0.0 7.2.1 8.1.4
meta ^1.3.0 1.15.0 1.15.0
riverpod ^0.14.0+3 0.14.0+3 2.5.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
freezed_annotation - 0.14.3 2.4.1
json_annotation - 4.9.0 4.9.0
state_notifier - 0.7.2+1 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.0` on bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^0.14.0+3` on riverpod does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions riverpod to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
130
pub points
0%
popularity

Publisher

unverified uploader

BlocProvider implementation with riverpod as alternative to provider.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, meta, riverpod

More

Packages that depend on bloc_riverpod