bloc_riverpod 0.0.2
bloc_riverpod: ^0.0.2 copied to clipboard

BlocProvider implementation with riverpod as alternative to provider.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add bloc_riverpod

With Flutter:

 $ flutter pub add bloc_riverpod

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  bloc_riverpod: ^0.0.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:bloc_riverpod/bloc_riverpod.dart';
3
likes
130
pub points
30%
popularity

BlocProvider implementation with riverpod as alternative to provider.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, meta, riverpod

More

Packages that depend on bloc_riverpod